using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\"":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)";
string substitution = @"\1'\2'\3";
string input = @"[
{
path: '/my-profile', name: 'my_profile', component: MyProfile,
child-ren: [
{
path: 'info', name: 'my_info', component: BasicInForm,
},
{
path: 'photos', name: 'my_photos', component: MyPhot'os,
},
{
path: 'questions', name: 'my_questions', component: MyQuestions,
},
],
},
{
path: '/', name: 'register', component: RegisterFormFlow,
},
]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}