import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\[\\{,:]+)(?!\\-?\\.?\\d|false\\W|true\\W)([^'\\\":,\\s\\]\\}]+)([:\\s,\\}\\]_\\-\\{\\[]|$)";
final String string = "[\n"
+ " {\n"
+ " path: '/my-profile', name: 'my_profile', component: MyProfile,\n"
+ " child-ren: [\n"
+ " {\n"
+ " path: 'info', name: 'my_info', component: BasicInForm,\n"
+ " },\n"
+ " {\n"
+ " path: 'photos', name: 'my_photos', component: MyPhot'os,\n"
+ " },\n"
+ " {\n"
+ " path: 'questions', name: 'my_questions', component: MyQuestions,\n"
+ " },\n"
+ " ],\n"
+ " },\n"
+ " \n"
+ " {\n"
+ " path: '/', name: 'register', component: RegisterFormFlow,\n"
+ " },\n"
+ "]";
final String subst = "\\1'\\2'\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}