# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)"
test_str = ("[\n"
" {\n"
" path: '/my-profile', name: 'my_profile', component: MyProfile,\n"
" child-ren: [\n"
" {\n"
" path: 'info', name: 'my_info', component: BasicInForm,\n"
" },\n"
" {\n"
" path: 'photos', name: 'my_photos', component: MyPhot'os,\n"
" },\n"
" {\n"
" path: 'questions', name: 'my_questions', component: MyQuestions,\n"
" },\n"
" ],\n"
" },\n"
" \n"
" {\n"
" path: '/', name: 'register', component: RegisterFormFlow,\n"
" },\n"
"]")
subst = "\\1'\\2'\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.