const regex = /([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\[\\{,:]+)(?!\\-?\\.?\\d|false\\W|true\\W)([^\'\\":,\\s\\]\\}]+)([:\\s,\\}\\]_\\-\\{\\[]|$)', 'g')
const str = `[
{
path: '/my-profile', name: 'my_profile', component: MyProfile,
child-ren: [
{
path: 'info', name: 'my_info', component: BasicInForm,
},
{
path: 'photos', name: 'my_photos', component: MyPhot'os,
},
{
path: 'questions', name: 'my_questions', component: MyQuestions,
},
],
},
{
path: '/', name: 'register', component: RegisterFormFlow,
},
]`;
const subst = `\1'\2'\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);