import Foundation
let pattern = ##"('|")([^\{\}]*)(\#\{([^\}]*)\})([^'"]*)('|")"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as'
"asdasd #{some} asda asd ${stuff} asdas as_ $asd#as"
'#{some}'
"#{some}"
"background-image: url(#{cover})"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$1+$4+$1$5$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)