import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('|\")([^\\{\\}]*)(\\#\\{([^\\}]*)\\})([^'\"]*)('|\")";
final String string = "'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as'\n"
+ "\"asdasd #{some} asda asd ${stuff} asdas as_ $asd#as\"\n"
+ "'#{some}'\n"
+ "\"#{some}\"\n"
+ "\"background-image: url(#{cover})\"";
final String subst = "$1$2$1+$4+$1$5$6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}