const regex = /('|")([^\{\}]*)(\#\{([^\}]*)\})([^'"]*)('|")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'|")([^\\{\\}]*)(\\#\\{([^\\}]*)\\})([^\'"]*)(\'|")', 'gm')
const str = `'asdasd #{some} asda asd #{asdasd} \${stuff} asdas as_ \$asd#as'
"asdasd #{some} asda asd \${stuff} asdas as_ \$asd#as"
'#{some}'
"#{some}"
"background-image: url(#{cover})"`;
const subst = `$1$2$1+$4+$1$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);