# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/('|")([^\{\}]*)(\#\{([^\}]*)\})([^'"]*)('|")/$1$2$1+$4+$1$5$6/gm;t' <<< "'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as'
\"asdasd #{some} asda asd ${stuff} asdas as_ $asd#as\"
'#{some}'
\"#{some}\"
\"background-image: url(#{cover})\""