package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)('|")([^\{\}]*)(\#\{([^\}]*)\})([^'"]*)('|")`)
var str = `'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as'
"asdasd #{some} asda asd ${stuff} asdas as_ $asd#as"
'#{some}'
"#{some}"
"background-image: url(#{cover})"`
var substitution = "$1$2$1+$4+$1$5$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}