# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"('|\")([^\{\}]*)(\#\{([^\}]*)\})([^'\"]*)('|\")"
test_str = ("'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as'\n"
"\"asdasd #{some} asda asd ${stuff} asdas as_ $asd#as\"\n"
"'#{some}'\n"
"\"#{some}\"\n"
"\"background-image: url(#{cover})\"")
subst = "$1$2$1+$4+$1$5$6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.