$re = '/(\'|")([^\{\}]*)(\#\{([^\}]*)\})([^\'"]*)(\'|")/m';
$str = '\'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as\'
"asdasd #{some} asda asd ${stuff} asdas as_ $asd#as"
\'#{some}\'
"#{some}"
"background-image: url(#{cover})"';
$subst = "$1$2$1+$4+$1$5$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;