// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)('|")([^\{\}]*)(\#\{([^\}]*)\})([^'"]*)('|")"#).unwrap();
let string = "'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as'
\"asdasd #{some} asda asd ${stuff} asdas as_ $asd#as\"
'#{some}'
\"#{some}\"
\"background-image: url(#{cover})\"";
let substitution = "$1$2$1+$4+$1$5$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}