import Foundation
let pattern = #"(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text""http://example.com/2016/10/26001140/blah.png@@more_text"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.jpg"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)