// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png").unwrap();
let string = "bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text\"\"http://example.com/2016/10/26001140/blah.png@@more_text";
let substitution = "$1.jpg";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}