$re = '/(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png/';
$str = 'bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text""http://example.com/2016/10/26001140/blah.png@@more_text';
$subst = "$1.jpg";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;