using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png";
string substitution = @"$1.jpg";
string input = @"bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text""http://example.com/2016/10/26001140/blah.png@@more_text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}