use strict;
my $str = 'bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text""http://example.com/2016/10/26001140/blah.png@@more_text';
my $regex = qr/(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png/p;
my $subst = '$1.jpg';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";