import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/example\\.com\\/.*?\\/.*?\\/.*?)\\.png";
final String string = "bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text\"\"http://example.com/2016/10/26001140/blah.png@@more_text";
final String subst = "$1.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}