package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png`)
var str = `bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text""http://example.com/2016/10/26001140/blah.png@@more_text`
var substitution = "$1.jpg"
fmt.Println(re.ReplaceAllString(str, substitution))
}