# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png"
test_str = "bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text\"\"http://example.com/2016/10/26001140/blah.png@@more_text"
subst = "$1.jpg"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.