import Foundation
let pattern = #"\$([a-z])(.*)(,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"($asset, $location);"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$job->get\U$1\L$2(),"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)