using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$([a-z])(.*)(,)";
string substitution = @"$job->get\U$1\L$2(),";
string input = @"($asset, $location);";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}