re = /\$([a-z])(.*)(,)/m
str = '($asset, $location);'
subst = '$job->get\\U$1\\L$2(),'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result