#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\$([a-z])(.*)(,)"
Local $sString = "($asset, $location);"
Local $sSubst = "$job->get\U$1\L$2(),"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)