# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$([a-z])(.*)(,)/$job->get\U$1\L$2(),/gm;t' <<< "($asset, $location);"