$re = '/\$([a-z])(.*)(,)/m';
$str = '($asset, $location);';
$subst = "$job->get\U$1\L$2(),";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;