use strict;
my $str = '($asset, $location);';
my $regex = qr/\$([a-z])(.*)(,)/mp;
my $subst = '$job->get\\U$1\\L$2(),';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";