const regex = /\$([a-z])(.*)(,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$([a-z])(.*)(,)', 'gm')
const str = `(\$asset, \$location);`;
const subst = `$job->get\U$1\L$2(),`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);