use strict;
my $str = '<i class="fa fa-eye-slash fa-lg"></i> Private Server<i>dedeee</i>';
my $regex = qr/<[a-zA-Z\/][^>]*>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";