const regex = /<[a-zA-Z\/][^>]*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[a-zA-Z\\\/][^>]*>', 'g')
const str = `<i class="fa fa-eye-slash fa-lg"></i> Private Server<i>dedeee</i>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);