import Foundation
let pattern = #"(\B)([A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
xCreatedBy
xCreatedTimestamp
CallTime
Notes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)