re = /(\B)([A-Z])/m
str = 'xCreatedBy
xCreatedTimestamp
CallTime
Notes '
subst = '_\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result