use strict;
my $str = 'xCreatedBy
xCreatedTimestamp
CallTime
Notes ';
my $regex = qr/(\B)([A-Z])/mp;
my $subst = '_\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";