using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\B)([A-Z])";
string substitution = @"_\2";
string input = @"xCreatedBy
xCreatedTimestamp
CallTime
Notes ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}