// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\B)([A-Z])").unwrap();
let string = "xCreatedBy
xCreatedTimestamp
CallTime
Notes ";
let substitution = "_\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}