package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\B)([A-Z])`)
var str = `xCreatedBy
xCreatedTimestamp
CallTime
Notes `
var substitution = "_\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}