const regex = new RegExp('(\\B)([A-Z])', 'gm')
const str = `xCreatedBy
xCreatedTimestamp
CallTime
Notes `;
const subst = `_\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);