$re = '/(\B)([A-Z])/m';
$str = 'xCreatedBy
xCreatedTimestamp
CallTime
Notes ';
$subst = "_\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;