import Foundation
let pattern = #"(^\w+ &.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Paul & Mary Atkins -
John Arnold & Dave Badman -
----DO NOT MATCH----
John Baines & Dave Adams -
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)