#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\w+ &.*)"
Local $sString = "Paul & Mary Atkins - " & @CRLF & _
"John Arnold & Dave Badman - " & @CRLF & _
"----DO NOT MATCH----" & @CRLF & _
"John Baines & Dave Adams - " & @CRLF & _
" "
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)