const regex = /(^\w+ &.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\w+ &.*)', 'gm')
const str = `Paul & Mary Atkins -
John Arnold & Dave Badman -
----DO NOT MATCH----
John Baines & Dave Adams -
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);