# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\w+ &.*)/$1/gm;t' <<< "Paul & Mary Atkins -
John Arnold & Dave Badman -
----DO NOT MATCH----
John Baines & Dave Adams -
"