package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\w+ &.*)`)
var str = `Paul & Mary Atkins -
John Arnold & Dave Badman -
----DO NOT MATCH----
John Baines & Dave Adams -
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}