use strict;
my $str = 'Paul & Mary Atkins -
John Arnold & Dave Badman -
----DO NOT MATCH----
John Baines & Dave Adams -
';
my $regex = qr/(^\w+ &.*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";