re = /(^\w+ &.*)/m
str = 'Paul & Mary Atkins -
John Arnold & Dave Badman -
----DO NOT MATCH----
John Baines & Dave Adams -
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result