$re = '/(^\w+ &.*)/m';
$str = 'Paul & Mary Atkins -
John Arnold & Dave Badman -
----DO NOT MATCH----
John Baines & Dave Adams -
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;