import Foundation
let pattern = #"^(Default=Profiles\/)(?:.)+(?'edition'default-release|dev-edition-default)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
[Install308046B0AF4A39CB]
Default=Profiles/idahodh8.default-release
Locked=1
[InstallCA9422711AE1A81C]
Default=Profiles/tf96jbvc.dev-edition-default
Locked=1
[Profile1]
Name=default-release
IsRelative=1
Path=Profiles/idahodh8.default-release
Default=1
[Profile0]
Name=dev-edition-default
IsRelative=1
Path=Profiles/tf96jbvc.dev-edition-default
[General]
StartWithLastProfile=1
Version=2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)