# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(Default=Profiles\/)(?:.)+(?'edition'default-release|dev-edition-default)$"
test_str = ("[Install308046B0AF4A39CB]\n"
"Default=Profiles/idahodh8.default-release\n"
"Locked=1\n\n"
"[InstallCA9422711AE1A81C]\n"
"Default=Profiles/tf96jbvc.dev-edition-default\n"
"Locked=1\n\n"
"[Profile1]\n"
"Name=default-release\n"
"IsRelative=1\n"
"Path=Profiles/idahodh8.default-release\n"
"Default=1\n\n"
"[Profile0]\n"
"Name=dev-edition-default\n"
"IsRelative=1\n"
"Path=Profiles/tf96jbvc.dev-edition-default\n\n"
"[General]\n"
"StartWithLastProfile=1\n"
"Version=2\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.