const regex = /^(Default=Profiles\/)(?:.)+(?'edition'default-release|dev-edition-default)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Default=Profiles\\\/)(?:.)+(?\'edition\'default-release|dev-edition-default)$', 'gmi')
const str = `[Install308046B0AF4A39CB]
Default=Profiles/idahodh8.default-release
Locked=1
[InstallCA9422711AE1A81C]
Default=Profiles/tf96jbvc.dev-edition-default
Locked=1
[Profile1]
Name=default-release
IsRelative=1
Path=Profiles/idahodh8.default-release
Default=1
[Profile0]
Name=dev-edition-default
IsRelative=1
Path=Profiles/tf96jbvc.dev-edition-default
[General]
StartWithLastProfile=1
Version=2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}