use strict;
my $str = '[Install308046B0AF4A39CB]
Default=Profiles/idahodh8.default-release
Locked=1
[InstallCA9422711AE1A81C]
Default=Profiles/tf96jbvc.dev-edition-default
Locked=1
[Profile1]
Name=default-release
IsRelative=1
Path=Profiles/idahodh8.default-release
Default=1
[Profile0]
Name=dev-edition-default
IsRelative=1
Path=Profiles/tf96jbvc.dev-edition-default
[General]
StartWithLastProfile=1
Version=2
';
my $regex = qr/^(Default=Profiles\/)(?:.)+(?'edition'default-release|dev-edition-default)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}